lkml.org 
[lkml]   [2002]   [Aug]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [BUG] initrd >24MB corruption
On Tue, Aug 27, 2002 at 08:05:14AM +0800, Jeff Chua wrote:
> On 26 Aug 2002, Alan Cox wrote:
> > > RAMDISK: Compressed image found at block 0 ... then stuck!
> > Force a 1K block size when you make the fs
>
> That was the default for mke2fs.
>
> Tried compress instead of gzip. Same problem. I guess the compressed file
> is too big for the kernel. The 8MB compressed (from 24MB) didn't work. 6MB
> compressed from 18MB worked. The 24MB filesystem has just one extra junk
> file in /tmp to fill up the filesystem to 90% and this caused the system
> to hang.
>
> I'm thinking it could be the ungzip function in the kernel that's causing
> the problem.

Out of curiosity, how much RAM do you have available?

--
Russell King (rmk@arm.linux.org.uk) The developer of ARM Linux
http://www.arm.linux.org.uk/personal/aboutme.html

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:28    [W:0.075 / U:2.672 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site