lkml.org 
[lkml]   [2002]   [Aug]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH] XFree v4.2.x DRM/DRI Support for 2.4.20-pre4
Date
Hi there,

this adds DRM/DRI Support for recent versions of XFree, f.e. v4.2.0 with a
slight modification. If you select SiS DRM Module, you also have to select
FrameBuffer SiS support otherwise it will result in unresolved symbols or
linking failure.

Without this patch you are not able to use DRI (Direct Rendering
Infrastructure) with XFree v4.2.0 and newer with the 7 provided kernel
modules (Banshee, ATI Rage/Radeon, i810/i830 etc.).

This is added to satisfy above:

...
+ if [ "$CONFIG_DRM_SIS" = "y" ]; then
+ define_bool CONFIG_FB_SIS y
+ fi
+ if [ "$CONFIG_DRM_SIS" = "m" ]; then
+ define_bool CONFIG_FB_SIS m
+ fi
...

Patch is attached to this mail.

Marcello, please apply for 2.4.20-pre5!


--
Kind regards
Marc-Christian Petersen

http://sourceforge.net/projects/wolk

PGP/GnuPG Key: 1024D/569DE2E3DB441A16
Fingerprint: 3469 0CF8 CA7E 0042 7824 080A 569D E2E3 DB44 1A16
Key available at www.keyserver.net. Encrypted e-mail preferred.

[unhandled content-type:application/x-bzip2]
\
 
 \ /
  Last update: 2005-03-22 13:28    [W:0.077 / U:0.932 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site