[lkml]   [2002]   [Aug]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [BUG] initrd >24MB corruption (fwd)


    Who else can help with this problem? I tried to write to Werner
    Almesberger <> (no such email) and Hans Lermen
    <>, but no response from either.

    I'm suspecting that somehow part of initrd is being corrupted during boot
    up or may be ungzip is not working properly, because I can definitely
    gzip/ungzip on all versions of running Linux for the ram.gz filesystem I
    created. Again, the only difference between ram-18mb.gz (6MB) and
    ram-24mb.gz (8MB) is ram24.gz contains one extra file to fill up the
    filesystem to 90%.

    Same bzImage, same ramdisk_size=28000, just different initrd files.
    ram-18mb.gz boots, ram-24mb.gz hangs.

    gzip 1.3.3

    I noticed that lib/inflate.c says gzip is based on gzip-1.0.3

    [ ]

    ---------- Forwarded message ----------
    Date: Tue, 27 Aug 2002 08:05:14 +0800 (SGT)
    From: Jeff Chua <>
    To: Alan Cox <>
    Cc: Linux Kernel <>
    Subject: Re: [BUG] initrd >24MB corruption

    On 26 Aug 2002, Alan Cox wrote:

    > > RAMDISK: Compressed image found at block 0 ... then stuck!
    > Force a 1K block size when you make the fs

    That was the default for mke2fs.

    Tried compress instead of gzip. Same problem. I guess the compressed file
    is too big for the kernel. The 8MB compressed (from 24MB) didn't work. 6MB
    compressed from 18MB worked. The 24MB filesystem has just one extra junk
    file in /tmp to fill up the filesystem to 90% and this caused the system
    to hang.

    I'm thinking it could be the ungzip function in the kernel that's causing
    the problem.


    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 13:28    [W:0.024 / U:38.524 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site