lkml.org 
[lkml]   [2002]   [Aug]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectOdd size mke2fs
Hi,
On my disk, I have an odd(not multiple of 4K)
number of sectors. There are
3104561 4K blocks or 12418245 1K blocks and
24836490 sectors.

mke2fs /dev/x
mount
umount
mke2fs /dev/x -b 1024
fails with message
"...resulted in short write at block 12418240.."

When it tried to write 5120 bytes, only 4096 bytes
are written.

That is due to blksize_size[][] array.
mount sets the field with 4096 and the last
sector became inaccessible in mke2fs.
When I tried after ioctl(.., BLKBSGSET, 1024),
mke2fs did work properly.

So should mke2fs use ioctl to set the block
or use get last sector ioctl?
Or is setting that back in umount a proper fix?

If anyone has faced this or is it well known,
please let me know.


Thanks,
Prasanna.

__________________________________________________
Do You Yahoo!?
HotJobs - Search Thousands of New Jobs
http://www.hotjobs.com
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:28    [W:0.025 / U:2.660 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site