lkml.org 
[lkml]   [2002]   [Aug]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectSystem freeze while reading a CD through cdparanoia
Hi,

Ok, I think I discovered a bug in the kernel
(and my thought is that it is located in the SCSI part).

The result of the bug is a complete freeze of my computer. It
still answer to 'ping' and seems to have his usual ports open,
but they are simply not working.

I already encountered this sort of behaviour on an Alsa-driver
bug. It was a deadlock because I have an SMP. I guess it is the
same now.

So, here is the recipe to make your brand new 2.4.19 crash
(I tried to isolate as much as possible the bug):

1) Get the last Maxi-single from Sophie Ellis Bextor
(It's called: Get Over You).

2) Try to rip the track 5 with cdparanoia. For example:
cdparanoia -Z 5

3) Wait a little bit... Bingo, you get it.

It's 100% reproducible. I never went through a complete
ripping session.

There is a lot of error messages appearing on the screen but
at the time it appear, I have no more control of anything...

I manage to copy down some:

Recovery code sleeping
(scsi:0:A:4:0): Abort Message Sent
Recovery code awake
Timer Expired
.... and so on.



Here are some infos about my computer:

[fleury@yggdrasil scripts]$ sh ./ver_linux
If some fields are empty or look unusual you may have an old version.
Compare to the current minimal requirements in Documentation/Changes.

Linux yggdrasil 2.4.19smp #2 SMP Sun Aug 18 22:13:39 CEST 2002 i686
unknown unknown GNU/Linux

Gnu C 2.95.4
Gnu make 3.79.1
util-linux 2.11n
mount 2.11n
modutils 2.4.19
e2fsprogs 1.27
Linux C Library 2.2.5
Dynamic linker (ldd) 2.2.5
Procps 2.0.7
Net-tools 1.60
Console-tools 0.2.3
Sh-utils 2.0.12
Modules Loaded snd-pcm-oss snd-mixer-oss snd-ens1370 snd-pcm
snd-timer snd-rawmidi snd-seq-device snd-ak4531-codec snd reiserfs soundcore


And, I attach my .config file to this mail.

The config should be tight enough to make you aware of most of
my hardware... I have also get the magic keys to work, but I
didn't get any useful information from it... :-/

I you need more information, or if you want me to perform so
tests, just ask. I would be always pleased to hunt a bug.

I don't know who's in charge for this bug because it is not
clear for me where the bug is located...

Regards
--
Emmanuel

Anyone who has never made a mistake has never tried anything new.
-- Albert Einstein

[unhandled content-type:application/x-java-vm]
\
 
 \ /
  Last update: 2005-03-22 13:22    [W:0.033 / U:3.328 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site