lkml.org 
[lkml]   [2002]   [Jul]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Linux 2.4.19-rc1-ac5
After many hours of trial and error I came to the
conclusion, that the problem must be in these lines
in the file drivers/ide/alim15x3.c

#ifdef CONFIG_BLK_DEV_IDEDMA
if (m5229_revision >= 0x20) {
/*
* M1543C or newer for DMAing
*/
hwif->dmaproc = &ali15x3_dmaproc;
#ifdef CONFIG_IDEDMA_AUTO
if (!noautodma)
hwif->autodma = 1;
#endif /* CONFIG_IDEDMA_AUTO */
}
#endif /* CONFIG_BLK_DEV_IDEDMA */

CONFIG_IDEDMA_AUTO will always be turned off by
make *config, but if I enable this option by
changing .config with a texteditor DMA actually
works.

This makes me ask the following questions?

1) Why can't CONFIG_IDEDMA_AUTO be enabled from
make *config?

2) What would it take to fix that?

3) How come DMA works fine with autodma=1, but
hdparm -d1 /dev/hda fails?

--
Kasper Dupont -- der bruger for meget tid på usenet.
For sending spam use mailto:razrep@daimi.au.dk
or mailto:mcxumhvenwblvtl@skrammel.yaboo.dk
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:22    [W:0.131 / U:0.052 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site