lkml.org 
[lkml]   [2002]   [May]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRE: pfn-Functionset out of order for sparc64 in current Bk tree?
Date
>  - pfn_to_page(pfn) is declared as (mem_map + (pfn)) for 
> i386. Can this
> apply to Sparc64 as well?
> - pte_pfn(x) is declared as
> ((unsigned long)(((x).pte_low >> PAGE_SHIFT)))
> in 2-level pgtable,
> (((x).pte_low >> PAGE_SHIFT) | ((x).pte_high << (32 - PAGE_SHIFT)))
> in 3-level. I suppose 2-level shouldn't exactly match
> here, how far
> must the 3-level version be changed in order to fit sparc64? A lot?
> - pfn_valid(pfn) is described as ((pfn) < max_mapnr).
> Suppose this is OK
> on Sparc64 either?
> - pfn_pte(page,prot) is defined as
> __pte(((pfn) << PAGE_SHIFT) | pgprot_val(prot))
> How far does this go for Sparc64?
>

I think about an hour or so ago, Tom Duffy posted some fixes to the
Sparclinux mailing list that may help you out. I cc'd them here. They may
help you out, I havn't looked at them yet, so YMMV.

Bruce H.

<snip>
On Sun, 2002-05-05 at 23:27, Keith Owens wrote:
> kbuild-2.5-common-2.5.14-1 and kbuild-2.5-i386-2.5.14-1 are available.
> Upgraded to kernel 2.5.14.

here is the sparc64 kbuild against core-11 and 2.5.14

you must apply the linux-2.5.14-sparc64-hacks.patch first to get sparc64
to build on 2.5.14 (even using kbuild 2.4)

0) untar linux-2.5.14.tar.bz2
1) apply linux-2.5.14-sparc64-hacks.patch
2) apply kbuild-2.5-core-11
3) apply kbuild-2.5-common-2.5.14-1
4) apply kbuild-2.5-sparc64-2.5.14-1

you should be good to go...

this patch still needs work on the asm-offsets to get it work The Right
Way (tm)

-tduffy
</snip>

[unhandled content-type:application/octet-stream][unhandled content-type:application/octet-stream]
\
 
 \ /
  Last update: 2005-03-22 13:25    [W:0.027 / U:20.392 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site