lkml.org 
[lkml]   [2002]   [May]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: USB host drivers test results (2.5.19) and problem.
    On Fri, May 31, 2002 at 08:44:42PM +0200, Stelian Pop wrote:
    > On Fri, May 31, 2002 at 09:39:14AM -0700, Greg KH wrote:
    >
    > > > > 1. Shouldn't the ehci/ohci drivers give some error on loading, since
    > > > > I obviously don't have the hardware ?
    > > >
    > > > How do they know that? You could have it in your hand and be just about to
    > > > insert it.
    > >
    > > They should not load, like any other pci driver that should not load if
    > > you don't have the hardware present for it.
    >
    > What about the PCI hotplug case, as David suggested ?

    When the pci hotplug core sees a new device it calls out to
    /sbin/hotplug to load any available driver (if necessary). So if you
    later plug in the device, everything will work just fine.

    Well, that's the way it's _supposed_ to work, but the pci core changes
    in 2.5.19 seem to have broken this too :(

    /me looks for Pat Mochel...

    thanks,

    greg k-h
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:26    [W:0.027 / U:0.084 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site