lkml.org 
[lkml]   [2002]   [May]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
Subject[2.4 patch] CONFIG_AGP_HP_ZX1 should only be available on ia64
Hi,

2.4.19-pre8 adds the CONFIG_AGP_HP_ZX1 config option that should only be
available on ia64 but it was selectable on i386. The problem seems to be
that IIRC the dependency on a symbol in dep_bool doesn't work if the
symbol is neither set or unset.

The following patch should fix this (tested only on i386):


--- drivers/char/Config.in.old Fri May 3 08:47:42 2002
+++ drivers/char/Config.in Fri May 3 08:49:04 2002
@@ -260,7 +260,9 @@
bool ' Generic SiS support' CONFIG_AGP_SIS
bool ' ALI chipset support' CONFIG_AGP_ALI
bool ' Serverworks LE/HE support' CONFIG_AGP_SWORKS
- dep_bool ' HP ZX1 AGP support' CONFIG_AGP_HP_ZX1 $CONFIG_IA64
+ if [ "$CONFIG_IA64" = "y" ]; then
+ bool ' HP ZX1 AGP support' CONFIG_AGP_HP_ZX1
+ fi
fi

bool 'Direct Rendering Manager (XFree86 DRI support)' CONFIG_DRM

cu
Adrian

--

You only think this is a free country. Like the US the UK spends a lot of
time explaining its a free country because its a police state.
Alan Cox

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:25    [W:0.034 / U:8.484 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site