lkml.org 
[lkml]   [2002]   [May]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject[OOPS] ide-2.4.19-p7.all.convert.8.patch piix_dmaproc/ide_dmaproc

Hi,
when running 2.4.19-pre7 + ide-2.4.19-p7.all.convert.8.patch i get
a crash on booting while detection of the onboard IDE controller.

00:1f.1 IDE interface: Intel Corp. 82820 820 (Camino 2) Chipset IDE U100 (rev 11) (prog-if 80 [Master])
Subsystem: Siemens Nixdorf AG: Unknown device 0055
Flags: bus master, medium devsel, latency 0
I/O ports at 2400 [size=16]

Oops is a "Null pointer dereference at 00000040"
EIP is "ide_dmaproc" + 1e
Call trace "piix_dmaproc" "ide_register_subdriver" "idedisk_init"

Decoded by hand. I tried with and with taskfile ..

Config snippet:

CONFIG_BLK_DEV_IDEDISK=y
CONFIG_IDEDISK_MULTI_MODE=y
CONFIG_BLK_DEV_IDECD=m
CONFIG_IDE_TASKFILE_IO=y
CONFIG_BLK_DEV_IDEPCI=y
CONFIG_IDEPCI_SHARE_IRQ=y
CONFIG_BLK_DEV_IDEDMA_PCI=y
CONFIG_IDEDMA_PCI_AUTO=y
CONFIG_BLK_DEV_IDEDMA=y
CONFIG_BLK_DEV_ADMA=y
CONFIG_BLK_DEV_PIIX=y
CONFIG_PIIX_TUNING=y
CONFIG_IDEDMA_AUTO=y
CONFIG_BLK_DEV_IDE_MODES=y

Flo
BTW: It seems linux/ide.h misses an include of linux/pci.h
--
Florian Lohoff flo@rfc822.org +49-5201-669912
Heisenberg may have been here.
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2005-03-22 13:25    [W:0.029 / U:0.856 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site