lkml.org 
[lkml]   [2002]   [May]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: ide dma timeout error, linux 2.4.9, PIIX4 Ultra 100
Hello Andrew...

Just came across your message. Your problem looks more or less
identical to the one I had, which corrupted some of my partitions.

The following sequence in particular appears to be the signature of the
bug that I have sort-of "fixed":
kernel: hda: status error: status=0x58 { DriveReady SeekComplete
DataRequest }
kernel: hda: drive not ready for command
kernel: hdb: ATAPI 24X DVD-ROM drive, 128kB Cache, UDMA(33)

The notable bit is that the 0x58 error + "drive not ready" error are
immediately followed by the ATAPI....UDMA message. Is this always the
case?

My "fix" doesn't cure the root problem but does cure the corruption
issues for me at least. Can you try it please and see if your 0x58
errors go away?

I posted it from my other email address (nconway_kernel@yahoo.co.uk) but
you should find it easily on any archive browser (this URL should work
http://marc.theaimsgroup.com/?l=linux-kernel&m=102098499900453&w=2 with
any luck). You want the "updated" patch that I posted last night. I
believe it should apply cleanly against the old 2.4.9 kernel.

cheers
Neil
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:22    [W:0.024 / U:1.876 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site