lkml.org 
[lkml]   [2002]   [Apr]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRE: [PATCH] reboot=bios is invalidating cache incorrectly
Date


> -----Original Message-----
> From: Martin Knoblauch [mailto:Martin.Knoblauch@TeraPort.de]
> Sent: Tuesday, April 23, 2002 8:51 AM
> Subject: Re: [PATCH] reboot=bios is invalidating cache incorrectly
>
>
> > [PATCH] reboot=bios is invalidating cache incorrectly
> >
> >
> > This patch applies cleanly to 2.4.18 and 2.5.8. It probably
> also works
> > with all 2.2.x, 2.4.x and 2.5.x kernels.
> >
> > This fixes a long standing bug that prevented reliable
> reboots on some
> > platforms.
> >
> Robert,
>
> care to specify which platforms? :-) I ask because I am experiencing
> reboot hangs between BISO and lilo on Tyan 2462 boards. Apparently
> others see similar things.
>

Martin,

I only have extensive experience with Dell's Server platforms. But because
of the nature of the error, it can happen on any platform using reboot=bios.

On the platforms I was debugging.. invalidating the cache left a bunch of
ADD's in memory followed by a JMP to itself. So you would see the message
"rebooting system" but then you would never get a blank screen and BIOS
posting (the reboot vector was never called).

- Robert
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:22    [W:0.032 / U:3.248 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site