lkml.org 
[lkml]   [2002]   [Apr]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] IDE TCQ #4
On Wed, 17 Apr 2002 12:32:15 +0200
Martin Dalecki <dalecki@evision-ventures.com> wrote:

> Sebastian Droege wrote:
> > On Wed, 17 Apr 2002 09:48:33 +0200
> > Martin Dalecki <dalecki@evision-ventures.com> wrote:
> >
> >
> >>Sebastian Droege wrote:
> >>
> >>>On Tue, 16 Apr 2002 20:09:14 +0200
> >>>Jens Axboe <axboe@suse.de> wrote:
> >>>
> >>>
> >>>
> >>>>On Tue, Apr 16 2002, Sebastian Droege wrote:
> >>>>
> >>>>
> >>>>>Hi,
> >>>>>just one short question:
> >>>>>My hda supports TCQ but my hdb doesn't
> >>>>>Is it safe to enable TCQ in kernel config?
> >>>>
> >>>>yes, should be safe.
> >>>>
> >>>>--
> >>>>Jens Axboe
> >>>>
> >>>
> >>>Ok it really works ;)
> >>>But there's another problem in 2.5.8 with ide patches until 37 applied (they don't appear with 2.5.8 and ide patches until 35), the unexpected interrupts (look at the relevant dmesg output at the bottom). They appear with and without TCQ enabled.
> >>>If you need more informations, just ask :)
> >>
> >>They are not a problem. They are just diagnostics for us and will
> >>go away at some point in time.
> >
> > Ok but there are actually 2 real problems then...
> > 1.
> > TCQ on hda is enabled with queue depth 32 and CONFIG_BLK_DEV_IDE_TCQ_FULL enabled
> > When I do many transfers on the hard disk I get a "ide_dma_queued_start: abort (stat=d0)" after some time and the IDE system doesn't respond anymore :(
> > 2.
> > when I cat /proc/ide/ide1/hdc/identify I get 2 unexpected interrupts
> > hdc and hdd are both cdrom drives (accessed via scsi-emulation if relevant) but the problem shows up only with hdc
> >
> > and maybe a third problem ;)
> > in /proc/ide/ide0/hda/tcq there is written:
> > DMA status: not running
> > but DMA is explicitly enabled by hdparm and shows up in /proc/ide/ide0/hda/settings
>
> Basically right now DMA on CD-ROM devices is "disabled" due to the
> fact that ide-cd.c is pasing struct packet_command through the rq->special
> field. This is subject to change soon becouse I'm right now adpting ide-cd
> to use the recently introduced struct ata_request stuff.
> So it doesn't make much sense if you test it - becouse the issues are just well
> known. However if you see an IDE xx which contains a "fix ide-cd blah blah" in
> the log - I would be really glad if you could have a look in to it.
>
Yeah sure but hda is a hard disk
The both cdrom drives aren't touched by hdparm
And I don't see such message (maybe because the both cdroms are accessed via scsi emulation?!) and atapi cdrom support isn't compiled into the kernel

Bye[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2005-03-22 13:25    [from the cache]
©2003-2011 Jasper Spaans