lkml.org 
[lkml]   [2002]   [Mar]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: Performance issue on dual Athlon MP
From
> I have a dual Athlon MP box (Tyan S2460 Tiger MP, 1.53 GHz, 2.5 GB Corsair
> PC2100). The initial installation was of SuSE 7.3, but I have upgraded to
> 2.4.17 with Andrea's 3.5 GB userspace patch.

> Is this a known problem with 2.4.17 and/or the 3.5 GB userspace patch? I
> have not tried turning off the 3.5 GB config option (`CONFIG_05GB'). I do
> have `CONFIG_MK7' set.

The configuration I would try first on 2.4.19pre1aa1 with 2.5 GB of RAM is
CONFIG_3GB=y and CONFIG_NOHIGHMEM=y. If that causes some other problem,
I'd go with CONFIG_2GB, then finally CONFIG_1GB. Each config changes
the user/kernel memory split. The loads I've run suggest for best
performance:

CONFIG_2GB > CONFIG_1GB > CONFIG_05GB

On my 1GB box, I've been running CONFIG_2GB for a couple months and
performance is great. Only lingering question for me is the handling
of oom. Oom hasn't caused be a problem, but I haven't seen the oom
killer do it's work when I create an oom condition.

BTW, Andrew Morton's read_latency2 patch is a winner. The read_latency2
diff I use on my 2.4.19pre1aa1 boxes is at:

http://home.earthlink.net/~rwhron/kernel/read_latency2-2.4.19pre1aa1.diff

--
Randy Hron

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:24    [W:0.033 / U:11.940 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site