lkml.org 
[lkml]   [2002]   [Mar]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [bug] 2.4.19-pre4-ac2 hang at boot with ALI15x3 chipset support
>> > After adding printk calls to alim15x3.c, it seems to hang during the
>> > pci_write_config_byte(isa_dev, 0x79, tmpbyte | 0x02) call on line 588.
>>
>> Does it work if you comemtn that line out ?

James> No, if the line is commented out I get:

James> hda: status error: status=0x58 { DriveReady SeekComplete DataRequest }
James> hda: drive not ready for command

I ran into this as well under various kernels including 2.4.18. Try
adding:
append="idebus=50"

to the lilo stanza for your kernel.

It seems even after I amputated the offending "write" that causes the
lockup, the bus speed was being set to 33MHz instead of 50Mhz. The
above solved the problem for me.

I don't need to specifically set idebus in the 2.5.7 version of the
driver so I assume something has been corrected in more recent
releases.

For anyone else trying to configure the pcg-c1mrx or pcg-c1mv, I'm
updating linux configuration document as I work through the
setup of the various devices:
http://hale.org/~bhoward/issue_7/pcg-c1mrx.html

Bruce
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:25    [W:0.043 / U:1.380 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site