lkml.org 
[lkml]   [2002]   [Mar]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: 2.4.18 freezes on heavy IO; SysRq question
From
Date
Richard Ems <r.ems.mtg@gmx.net> writes:

> Hi all!
>
> I'm seeing my system freeze on heavy IO. Only the reset button brings it
> back to life again (ALT-SysRq-b also worked once). I'm running SuSE's
> 2.4.18-30 on a Pentium III (Coppermine) with 256 MB RAM (yes, I should
> try vanilla 2.4.18, I will ...)
> No SCSI, all IDE. LVM and ext3.
> I don't get any oopses, no entries in /var/log/messages, nothing. I
> mounted the ext3 partitions with the debug option but still no messages.
> What options can I turn on to search for the problem? Any kernel boot
> options? LVM/ext3 options?

Seconded; happened to me with 2.4.18 from kernel.org + LVM 2.0 beta
1.1 + Trond's NFS ('current' for 2.4.18). IO was to a local ext3 fs;
no LVM on that machine (modules not loaded).

Lock-up was complete for me; no panic message and no IP either so I
couldn't poke around. Alt+Sysrq seemed dead; but it might have been on
one of the boxen where Linux does not detect Alt+Sysrq properly.

BTW, what's the status of the Sysrq entry key "decoder"? I've about 4
different types of keyboards here, as far as I could determine only
one of them sends Linux-parseable Alt-Sysrq. All do send *something*
on Alt-Sysrq, though; but I couldn't get them to work with the
procedure described in the SysRq manual. That was around 2.4.12.


So long,
Joe

--
"I use emacs, which might be thought of as a thermonuclear
word processor."
-- Neal Stephenson, "In the beginning... was the command line"
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:21    [W:0.107 / U:1.144 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site