lkml.org 
[lkml]   [2002]   [Mar]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Multiple kernels OOPS at boot on Fujitsu pt510 ( AMD DX100 CPU ) - ksymoops output attached
On Fri, 1 Mar 2002, Zwane Mwaikambo wrote:

> On Fri, 1 Mar 2002, Richard B. Johnson wrote:
>
> > Turn off CONFIG_X86_WP_WORKS_OK and CONFIG_X86_CMPXCHG. This allows
> > booting using Linux Version 2.4.1.
>
> I'm sure others have asked you before, why do you have an obsession
> with 2.4.1?
>
> Thanks,
> Perplexed.

Later versions, including the current 2.4.18 fail, to mount an initrd.
Since I use the same kernel for everything (very small), with different
modules as different machines may require, I need a working initrd.

This machine, and several others, require SCSI modules to be installed
before the final root file-system is accessible. The last kernels I've
tried, 2.2.17 and 2.2.18 find a compressed file-system for initrd, then
promptly free it. I end up with a panic can't mount root on 1:0. This
is /dev/ram0. I have tried /dev/ram1 (1:1) as well. The kernel recognizes
what file-system it should mount, but doesn't. This has been reported
on LK several times over the past year. I even provided a script that
any interested person can execute to make an 'initrd floppy' to verify
that a root file-system can be found and mounted. The only responses
I got were things like; "You should use cramfs". I need an ext2
file-system on the RAM Disk. I guess there's no longer any interest
in that amongst kernel developers.

Once somebody makes a kernel they has both a working loop device and
a working initial RAM Disk, I will use that kernel. In the meantime,
I'm stuck at 2.4.1.


Cheers,
Dick Johnson

Penguin : Linux version 2.4.1 on an i686 machine (797.90 BogoMips).

111,111,111 * 111,111,111 = 12,345,678,987,654,321

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:21    [W:0.046 / U:2.864 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site