lkml.org 
[lkml]   [2002]   [Feb]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectWeird bug in linux, glibc, gcc or what?
Hi,

I've found a weird problem in linuxthreads. When I get out of a thread it
happends one of three, the new thread get's defuct and the proccess never
ends, it segfaults, or it works.

The most weird is that it depends on the kernel, and also when I run the
test trought gdb there is no problem.

Here is the test:

#include <pthread.h>

void *test(void *arg) {
puts("Thread2");
return 0;
}

int main() {
pthread_t tt;
puts("Before Thread2");
pthread_create(&tt,NULL,test,NULL);
puts("After Thread2");
return 0;
}

The output:

1:src# ./test
Before Thread2
After Thread2
Thread2

This time it just kept waiting:

8957 vc/1 00:00:00 test
8958 ? 00:00:00 test <defunct>

I run it again:

1:src# ./test
Before Thread2
After Thread2

And again:

1:src# ./test
Before Thread2
Thread2
Segmentation fault

Now with gdb-5.1.1:

Starting program: /usr/src/./test
(no debugging symbols found)...[New Thread 1024 (LWP 9168)]
Before Thread2
[New Thread 2049 (LWP 9169)]
[New Thread 1026 (LWP 9170)]
Thread2
After Thread2

Program exited normally.

As I said the results vary from system to system, here are some
convinations:

* linux-2.4.10+glibc+2.2.4+gcc-2.95.3: Runs fine, but once in a while it
keeps waiting for the defunct thread.

* linux-2.4.17+glibc+2.2.4+gcc-2.95.3: The same, but the defunct problem
happends much more often.

* linux-2.4.10+glibc+2.2.5+gcc-3.0.3: Segfaults or waits for defuncts.

* linux-2.4.17+glibc+2.2.5+gcc-3.0.3: The same.

I'm lost on this, I supose it's a convination of glibc-linux problem.

Any ideas?

--
Felipe Contreras
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:24    [W:0.035 / U:0.120 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site