lkml.org 
[lkml]   [2002]   [Feb]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: Linux 2.4.19pre1-ac1
Date
Hi Florin, hi Alan,

> With 19-pre1-ac1 on a reiserfs partition I cannot patch a kernel. Patch
> fails with "Invalid cross-device link" or "Out of disk space".

I can reproduce this too on ext2, so this does not seem to be FS related.

However, I do not get this error messages, the patch runs just fine,
but corrupts all files it touches, leaving them to be all a bit less than
1MiB of size, and all exactly the same size.

There is no filesystem corruption however, e2fsck runs just fine without any
error. Just the files are all damaged. I looked inside them, and it seems
huge parts of other files from the patch have been "attached" to them.

> 18-rc2-ac1 works fine on the same partition.

ACK, for me too; as well as 2.4.18-rc2-ac2 for me. The breakage starts with
2.4.18-ac1 here. Plain 2.4.18 from Marcelo works fine as well.

Greetings,
Andreas
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:24    [W:0.050 / U:2.456 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site