lkml.org 
[lkml]   [2002]   [Feb]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Linux 2.5.5-dj1 - problem with /dev/input/mice
On Sun, Feb 24, 2002 at 01:00:00PM -0800, Ben Clifford wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
>
> > > -dj includes a different input layer to Linus' tree, which requires
>
> I've just moved from Linus 2.5.3 to 2.5.5-dj1.
>
> I've tried the following both with modules and linked into bzImage.
>
> I've tried pointing the software at /dev/input/mice and also at /dev/psaux
> which I created as a symlink to /dev/input/mice (to maintain compatibility
> with my working 2.5.3 setup)
>
> I have a PS/2 mouse.
>
> I've loaded mousedev.o and psmouse.o
>
> gpm works. (**1)
>
> cat /dev/input/mice
> gives random binary spew that looks pretty much like mouse input.
>
> When I run my Xserver, the mouse pointer doesn't move. If I then kill off
> the Xserver, gpm doesn't work any more and cat/dev/input/mice doesn't
> generate anything any more.
>
> If I unload psmouse.o and then load it again, I am back to (**1) until I
> load the Xserver again.

That's interesting. It almost looks like if the Xserver messed with the
mouse hardware somehow, which I hope it can't. Does 'dmesg' say anything
relevant?

I can help you find the cause - if you enable I8042_DEBUG_IO in
drivers/input/serio/i8042.h, you'll see all the data coming in and out
to the keyboard/aux controller.

--
Vojtech Pavlik
SuSE Labs
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:24    [W:0.062 / U:4.516 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site