lkml.org 
[lkml]   [2002]   [Feb]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Seagate IDE tape problems
Pete Zaitcev wrote:
>
> > I'm having trouble with a Seagate IDE tape drive that previously
> > worked with 2.2.x kernels. (tape is a STT8000A travan drive)
> >[...]
> > PIIX4: not 100% native mode: will probe irqs later
> > ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:pio
> > ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:DMA
> > hda: SAMSUNG SV2042H, ATA DISK drive
> > hdc: SAMSUNG SV3063H, ATA DISK drive
> > hdd: Seagate STT8000A, ATAPI TAPE drive
>
> Make sure you switched DMA off with hdparm -d0.
> You must find corresponding /dev/hdX, hdparm does not work
> on /dev/ht0. If is a known problem (Red Hat bug #54517).
>
> BTW, if you have trouble with Red Hat kernels, you may find
> better luck trying Red Hat support. What if I did not see
> your message here?

Because it was related to ide-tape (which I don't use) and
it also was about the tape not working at all or with massive amounts
of errors. Which I already know, bacause I tried it.
I now run with the SCSI emulation (scsi_mod, ide-scsi etc) and it
seems to *almost* work fine...

I'll try with DMA off and see what happens, but that should slow down
the other HDD on the bus, right?

Is there any known problems with changing the DMA settings back
and forth on a live production system?


/magnus

>
> -- Pete
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:24    [W:0.028 / U:3.944 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site