lkml.org 
[lkml]   [2002]   [Feb]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectChanging PCI board's IRQ
Date
Hello,

One computer that I administer have a IRQ conflict between a sound card and a
ethernet card. Both share the IRQ 11.
I don't have physical access to the computer, so I tried to change the IRQ
using the 'setpci' command.

# setpci -v -s 0:7.5 INTERRUPT_LINE=08
00:07.5:3c 08
#

But, after that, when I did a

# lspci -vv -s 0:7.5
00:07.5 Multimedia audio controller: VIA Technologies, Inc. AC97 Audio
Controller (rev 50)
Subsystem: Biostar Microtech Int'l Corp: Unknown device 0032
Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
Interrupt: pin C routed to IRQ 11
Region 0: I/O ports at dc00 [size=256]
Region 1: I/O ports at e000 [size=4]
Region 2: I/O ports at e400 [size=4]
Capabilities: [c0] Power Management version 2
Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-


After some experience (like rebooting... arg!) i tried:

# lspci -vv -H1 -s 0:7.5
<cut>
Interrupt: pin C routed to IRQ 8
Region 0: I/O ports at dc00
<cut>

So, it seems that either I cannot change the Interrupt line number throught
software (and the -H1 is tricky) or the /proc/pci (and /proc/bus/pci) is not
getting updated.

Is that a problem or am I missing the point?

P.S.: Please Reply direct to me (or send me a copy) because I can not
"afford" the traffic of linux-kernel. :)

--
Raphael Derosso Pereira - DephiNit

*-=-*-=--=-*-=-*-=--=*=-*
/ dephinit@softhome.net /
*-=-*-=--=-*-=-*-=--=*=-*

-=*=--=*=--=*=--=*=--=*=--=*=--=*=-
| Debian GNU/Linux Addicted User |
| Use it, Abuse it. It's Free!!! |
-=*=--=*=--=*=--=*=--=*=--=*=--=*=-
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:24    [W:0.063 / U:0.044 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site