lkml.org 
[lkml]   [2002]   [Dec]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Subject[PATCH] __deprecated requires gcc 3.1
From
Date
Linus,

James Bottomley confirmed the "deprecated" attribute requires gcc 3.1
and onward, not gcc 3.0.

Attached patch updates the check in compiler.h to require gcc 3.1 or
greater.

Patch is against current BK, please apply.

Robert Love

include/linux/compiler.h | 5 ++---
1 files changed, 2 insertions(+), 3 deletions(-)


diff -urN linux-2.5.53/include/linux/compiler.h linux/include/linux/compiler.h
--- linux-2.5.53/include/linux/compiler.h~ 2002-12-31 17:27:53.000000000 -0500
+++ linux/include/linux/compiler.h 2002-12-31 17:29:09.000000000 -0500
@@ -17,10 +17,9 @@
* Allow us to mark functions as 'deprecated' and have gcc emit a nice
* warning for each use, in hopes of speeding the functions removal.
* Usage is:
- * int deprecated foo(void)
- * and then gcc will emit a warning for each usage of the function.
+ * int __deprecated foo(void)
*/
-#if __GNUC__ >= 3
+#if ( __GNUC__ == 3 && __GNUC_MINOR > 0 ) || __GNUC__ > 3
#define __deprecated __attribute__((deprecated))
#else
#define __deprecated


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:32    [W:0.034 / U:3.508 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site