[lkml]   [2002]   [Nov]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] PARAM 2/4

On Sat, 16 Nov 2002, Rusty Russell wrote:
> MODULE_PARAM is misleading and wrong.

Why is MODULE_PARAM() misleading and wrong? I think it's a lot more
descriptive, and these things are "modules" whether they are actually
compiled in or not.

The MM layer is just "another module". Granted, you can't compile it out
of the kernel, but it has a specific set of things it does, and is clearly
not the same thing as the scheduler, which is it's own "module".

The fact that PARAM was already used as a name should have been a big hint
that the name is not specific or descriptive enough.

Also, can we please stop shouting? I'd much rather see

module_param(debug, int, 0600)


PARAM(debug, int, 0600)

(see, for similarities, "module_init()", "module_exit()" etc: you don't
need to shout to make a point, and "module_xxx()" is already the accepted
practice for something that works both for compiled-in and modular


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:31    [from the cache]
©2003-2014 Jasper Spaans. hosted at Digital Ocean