[lkml]   [2002]   [Nov]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [PATCH] eliminate pci_dev name
    On Thu, Nov 14, 2002 at 10:36:03AM -0800, Linus Torvalds wrote:
    > Actually, I think we should do the reverse (for testing), and make the
    > name be something small like 8 bytes, and make sure that everybody who
    > writes the name uses strncpy() and snprintf() instead of just blindly
    > writing whatever is in the database.
    > Otherwise we'll always end up having fragile magic constants.
    > Anybody willing to do that cleanup?

    Sure, I can do that. That leads me to think that maybe we should
    delete name from struct device and just use the one in struct kobject
    (which is already a mere 16 bytes). But if we're going to go as far
    down as the kobject... that has a dentry. And dentrys have names.
    So how about eliminating that too and just creating a dentry with the
    almost infinitely long name?

    Maybe that's too much at this stage of the game.

    Revolutions do not require corporate support.
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 13:31    [W:0.020 / U:117.300 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site