[lkml]   [2002]   [Oct]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: Linux 2.5.44-ac1
    On Wed, 2002-10-23 at 07:49, Alan Cox wrote:
    > > code within the ide_iomio_dma function in ide-dma.c The problem shows
    > > itself if you only enable the secondary channel of your IDE controller.
    > > I understand this is a strange set up, but it could happen in a machine
    > > that boots off of SCSI and uses IDE disks for DATA or a CD Burner. I
    > > came up with a fix, some extra sanity checks before this line in the
    > > code:
    > Yes I saw the report. I've not applied it because I want to know how
    > the slave came not to have a hwif->mate even though it was bios disabled.
    > There are other things that really mean we should be assigning the hwif
    > pointers (eg hot plugging)

    That is what I thought you might say. I have been digging around in the
    code, trying to figure out the answer to that question myself. For some
    reason, even though that patch worked, it just didn't 'feel' right. I
    was looking for someone to confirm that there was a bigger problem to
    search for. Now I'll go back and hunt down the bigger beast and find
    out why that hwif->mate is coming out null.


    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 13:30    [W:0.020 / U:8.444 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site