lkml.org 
[lkml]   [2002]   [Oct]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
Subject2.5.43: "fix old protocol handler pppoe_rcv+0x0/0x124 [pppoe]"

In linux-2.5.42 and .43, I get this recurring error message:

fix old protocol handler pppoe_rcv+0x0/0x124 [pppoe]

which is apparently from deliver_to_old_ones() in net/core/dev.c:

#if CONFIG_SMP
/* Old protocols did not depened on BHs different of NET_BH and
TIMER_BH - they need to be fixed for the new assumptions.
*/
print_symbol("fix old protocol handler %s!\n", (unsigned long)pt->func)\
;
#endif

I'm puzzling out exactly change this message is requesting,
and I thought it might be a better use of everyone's time if I first
ask if there is a porting guide or other document about converting an
"old" style protocol handler to a "new" one.

Adam J. Richter __ ______________ 575 Oroville Road
adam@yggdrasil.com \ / Milpitas, California 95035
+1 408 309-6081 | g g d r a s i l United States of America
"Free Software For The Rest Of Us."
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:30    [W:0.032 / U:1.620 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site