[lkml]   [2002]   [Oct]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
Subject2.5.42 broke ARM zImage/Image

I'm trying to get 2.5.42 to build on ARM, and I've finally run out of
ideas for things to try to get arch/arm/boot/Makefile and
arch/arm/boot/compressed/Makefile to work correctly.

What I'm seeing is:

/home/rmk/bin/arm-linux-ld -p -X -T head.o misc.o piggy.o /home/rmk/arm-linux/lib/gcc-lib/arm-linux/2.95.3/libgcc.a -o vmlinux
/home/rmk/bin/ parse error
make[2]: *** [vmlinux] Error 1
make[1]: *** [compressed/vmlinux] Error 2
make: *** [zImage] Error 2

This appears to be because ZRELADDR is not passed from arch/arm/boot/Makefile
to arch/arm/boot/compressed/Makefile. You may think this is fairly trivial
to fix, just export it. However, it is already exported with a bunch of
other symbols. Other symbols seem to make it through to compressed/Makefile

I've tried many things, like including $(TOPDIR) Rules.make at the top of
arch/arm/boot/Makefile, but this doesn't seem to make any difference what
so ever.


Unless this can be solved, I'm going to be pushing _compile only_ tested
stuff to Linus in the forthcoming weeks until someone can provide some
hints as to what and why this broke.

Russell King ( The developer of ARM Linux

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:30    [W:0.056 / U:4.964 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site