lkml.org 
[lkml]   [2002]   [Jan]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: eepro (82595) question
From
> I have two 82595FX Ethernet ISA cards. I can load eepro module with
> autodetect=1, irq and io are detected correctly, then I can ifconfig eth0 up,
> but card no works at all (I can ping it, but can't ping something else). I
> tried that card in Win98 - works with "Intel 82595" driver. So I downloaded
> "e10disk.exe" with DOS utils. With softset2.exe I changed irq to 10 and io to
> 0x300. I booted Linux-2.2.19 and loaded eepro, detected again, and now it
> works! But I need to put two cards in one system, so I must find another
> working irq/io. My question is why it doesn't work with many irq/io settings?
> I tried 5 times. Only irq=10, io=0x300 works correctly (on 3 different
> computers). Of course I checked /proc/interrupts and /proc/ioports for
> conflicts. Is it possible that driver is broken? I searched groups.google.com
> and found few posts from people with similiar problem, maybe they couldn't find
> correct softset2.exe and correct irq/io settings?
2.2.19 and 2.2.20 drivers are broken. check for 0.13 version of driver
(http://cathedrallabs.org/~aris/patches/)

--
aris
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:15    [W:0.090 / U:0.084 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site