lkml.org 
[lkml]   [2002]   [Jan]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectFaced a problem with rtnetlink socket ( RTM_DELLINK)
Date
Hello All,

I am facing a problem in using rtnetlink sockets and thought that
this mailing list would be the better to place to clarify.
Can anyone calrify my query.

When I tried deleting an interface, I have received message
RTM_NEWLINK (instead of RTM_DELLINK) from kernel.

I have executed the attached program and did "/sbin/ifdown eth0"..
and my program received a messsage RTM_NEWLINK from kernel
instead of RTM_DELLINK.

When I tried adding the interface "/sbin/ifup eth0".. it works fine
and received RTM_NEWLINK.

I would like to know whether anyone has faced this problem or
am I missing something in my program.

Thanks,
Rajesh.










[unhandled content-type:application/octet-stream]-----------------------------------------------------------------------------------------------------------------------
Information transmitted by this E-MAIL is proprietary to Wipro and/or its Customers and
is intended for use only by the individual or entity to which it is
addressed, and may contain information that is privileged, confidential or
exempt from disclosure under applicable law. If you are not the intended
recipient or it appears that this mail has been forwarded to you without
proper authority, you are notified that any use or dissemination of this
information in any manner is strictly prohibited. In such cases, please
notify us immediately at mailto:mailadmin@wipro.com and delete this mail
from your records.
------------------------------------------------------------------------------------------------------------------------
\
 
 \ /
  Last update: 2005-03-22 13:15    [W:0.048 / U:2.104 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site