lkml.org 
[lkml]   [2001]   [Sep]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: OOPS[devfs]: reproducible in vfs_follow_link 2.4.9,2.4.10-pre4
Richard Gooch wrote:
>
> Alexander Viro writes:
> >
> >
> > On Thu, 6 Sep 2001, Giacomo Catenazzi wrote:
> >
> > > Hello.
> > >
> > > Since yesterdey, every time I run a 2.4.9 or 2.4.10pre-4 without the
> > > "devfs=nomount" I
> > > have two oops + /usr, /home /boot not mounted (all (also /): ext2).
> >
> > Don't use devfs. One of the known bugs - devfs passes a string
> > to vfs_follow_link() and doesn't care to preserve it until
> > vfs_follow_link() is done.
>

>
> If people could test the latest devfs patch, that would be really
> helpful. Linus isn't applying it because he's concerned that the many
> SD support may break something. Even if you don't have many SD's,
> please apply the patch and send a message to the list (and Cc: me)
> stating whether or not your system still works.
>

No, your patch didn't work.
I have still the oops.

I investigates, and the oops come in the mountall script (in init.d),
when running: mount -avt nonfs,nosmbfs.
(I noticed thet at this point kernel load floppy modules, but when I
removed also the floppy module, the oops reappers.)

Note: only the first time I run the script the kernel oops, thus
on normal boot sequence debian would not mount my partitions :-(.

giacomo
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:02    [W:0.049 / U:1.584 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site