lkml.org 
[lkml]   [2001]   [Sep]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRE: apm suspend broken in 2.4.10
Date
From: Randy.Dunlap [mailto:rddunlap@osdlab.org]

> > -0xe1a
> {little-endian n[iy]bbles ?}

It's just the closest I can get to my own name in hex. ;)

> Sounds like our 2.4.10's are different then. :)

It's possible... I got mine from kernel.org, applied the preemptible-kernel
and ext3fs patches, and compiled with RH's "kgcc"

> Without this patch, mine didn't create /proc/apm, register as a
> misc device, or create the kapmd-idle kernel thread.
> Must be a distro thingy.

Did you have apm=on set before, or nothing at all? Here's what I've seen so
far:

In all cases, I've got apm compiled into the kernel, not a module.

- With 2.4.10, Before your patch, with no apm= option in the kernel command
line, APM in general works, but suspend doesn't. When I append apm=on or
apm=off to my kernel command line, APM is disabled.
- With 2.4.10, After applying your patch, apm=on no longer disables APM, but
suspend still doesn't work.

> Return of EAGAIN from the SUSPEND ioctl means that
> send_event() failed, which means that some device driver
> didn't want suspend to happen...which means that some
> device driver got changed. :(

Just for fun, I tried removing all of my loaded 2.4.10 modules one by one,
and attempting 'apm --suspend' in between, and still had the same problem
when I got down to the bare minimum (ext3 and jbd)

> What was the last working kernel AFAUK (for this APM stuff)?

I just checked, and the RH-compiled 2.4.9-0.5 doesn't suspend either. It
appears to suffer from the same "apm=on" command-line bug too. I'm gonna go
try the 2.4.7 from RH's "Roswell" beta now.

-0xe1a
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:03    [W:0.035 / U:20.756 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site