lkml.org 
[lkml]   [2001]   [Sep]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectSomething Broken in 2.4.9-ac15
On Mon, Sep 24, 2001 at 08:29:44PM -0400, Michael Rothwell wrote:
> my swap load is at zero, which is probably where it should be (2.4.7
> would regularly be using 256MB of swap with the same applications
> running).

That got my attention. I think something is broken here and you
are into swap but the reporting is quite wrong.

I have 192 MB in my laptop running 2.4.9-ac15 w/preemption patch
turned on. I fired up a couple Mozilla windows, a couple Netscape
windows, Staroffice, a couple acroread windows, a couple emacs
windows, Abiword, and I forget what all. Still no swap usage
reported. I fired up a second X session and my computer came to a
crawl as it tried to run all those apps again. The disk was grinding
away--it felt just like a swapping death and yet xosview and top both
reported 0 swap usage. I don't believe it was so.

I killed most everything, and now the computer feels like it is back
to normal, but xosview thinks the CPU is pinned at 100% SYS when
nothing is going on. I drag a window around and I get plenty of USR
and even some FREE, but let go and it goes back to 100%.

Something is broken here, me thinks.


-kb, the Kent who might go back to 2.4.9-ac12 later today and ry it
again.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:03    [W:0.126 / U:1.156 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site