Messages in this thread |  | | Date | Tue, 18 Sep 2001 19:20:56 -0700 | From | Dan Kegel <> | Subject | re: [PATCH] /dev/epoll update ... |
| |
Davide wrote:
> The /dev/epoll patch has been updated : > > *) Stale events removal > *) Help in Configure.help ( thanks to David E. Weekly ) > *) Fit 2.4.9 > ... > http://www.xmailserver.org/linux-patches/nio-improve.html
Davide, I'm getting ready to stress-test /dev/epoll finally. In porting my Poller_devpoll.{cc,h} to support /dev/epoll, I noticed the following issues:
1. it would be very nice to be able to expand the interest list without affecting the currently ready list. In fact, this may be needed to support existing programs. A quick look at your code gives me the impression that it would be easy to add a ioctl(kdpfd, EP_REALLOC, newmaxfds) call to do this. Do you agree?
2. The names made visible to userland by your patch do not follow a consistent naming convention. May I suggest that you use EPOLL_ as a uniform prefix, and epoll.h as the user-visible include file? http://www.opengroup.org/onlinepubs/007908799/xsh/compilation.html shows that Posix cares greatly about this kind of namespace issue, and it'd be nice to follow their lead, even though this isn't a Posix interface.
3. You modify asm/poll.h. Can your modifications be restricted to epoll.h instead? (Hey, I don't know much, maybe there's a good reason you did this.)
Thanks, Dan Kegel - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
|  |