lkml.org 
[lkml]   [2001]   [Sep]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Booting linux using Novell NetWare Remote Program Loader
Pavel Machek wrote:

> Hi!
>
>>>>I removed the autoprobing from bootsect.S and fixed it to 1.44MB format
>>>>et voila, it worked perfectly.
>>>>
>>>Do you have patch to do that?
>>>
>>I have a patch for 2.0.x only. But it should be enough to change the
>>disksizes table at the end of bootsect.S to:
>>
>>disksizes: .byte 18,18,18,18
>>
>
> Yep, tried that. No more crc errors when decompressing. Instead,
> sudden reboot when it finishes loading. OOps.
>
> This is 486sx/25 booting from network. Kernel is 2.4.9, compiled with
> math emu, and processor=386. Any ideas what is wrong?
> Pavel


Am I guessing correctly that this RPL thing is a floppy image emulator?
Then it probably becomes a matter of where that image lives (in memory, if
so where; or on the network and downloaded sector by sector.) You may
want to try to make a SYSLINUX image and see if it works.

-hpa


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:03    [W:0.287 / U:23.348 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site