lkml.org 
[lkml]   [2001]   [Sep]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Booting linux using Novell NetWare Remote Program Loader
Pavel Machek wrote:
>
> I found out I can boot it after little games with mars netware
> emulator. However I have problems booting anything else than
> freedos. Trying to boot zImage directly results in crc errors or in
> errors in compressed data. Too much failures and too repeatable
> (althrough ram seems flakey) for me to believe its hw.

I bet that's the same problem I had booting a zImage directly from an
El-Torito CD. The problem was the autoprobing for the floppy type
performed by the boot loader. It detected a 2.88 drive and issued
corresponding read requests (track x, 36 blocks; track x+1, 36 blocks;
...). The bios performs these request, but it emulates a 1.44 disk so
the last 18 blocks of track x are actually the blocks from track x+1.
In my case I did not even got a crc error but an immediate reboot.

I removed the autoprobing from bootsect.S and fixed it to 1.44MB format
et voila, it worked perfectly.

Ciao, ET.

PS: Maybe that's the same problem lilo has on some systems with the
linear option...
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:17    [W:0.155 / U:4.152 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site