[lkml]   [2001]   [Sep]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
Subjectps -ef hangs on linux-2.4.9
Hello ,
I am running a multithreaded daemon on the 2.4.9 kernel. One of
the threads of the daemon is getting a SIGSEGV. After this when I tried to
find the process state using the command:
$ ps -ef
This just hangs, Ctrl-C or Ctrl-Z also does not interrupt this. The
only option I have is to reboot machine.
When I did a strace on the same command, I found out that ps -ef , was
hanging when it tried to read from the /proc/<pid of killed daemon>/*.
Is there any way I can reset the /proc directory without rebooting the
machine. After this , even the killall -9 does not work , even this
command hangs.
Any help will be of real great value. Thank you for the help.


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:03    [W:0.019 / U:0.024 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site