[lkml]   [2001]   [Aug]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [OOPS] repeatable 2.4.8-ac7, 2.4.7-ac6 just run xdos
Paul wrote:
> * Kernel oops, and locks up when I run xdos (dosemu)
> * Occuring in both 2.4.7-ac6 and 2.4.8-ac7. Run 'xdos' in X, and
> machine locks hard, only output to console is oops. (no sysrq)
> Tried once with strace, but no oops. (didnt wait long, though)
> Some oops before window is placed, some a little while after.
> (mouse movement?) Repeatable.
> * Kernels are virgin linus patched with ac. AMD-K6(tm) 3D
> processor
> * If anyone wants any more info or for me to do anything, just
> ask.
> Paul
> (2.4.7-ac6 -- two captured, identitcal, first shown)
> ksymoops 2.4.1 on i586 2.4.7-ac6. Options used
> -V (default)
> -k /proc/ksyms (default)
> -l /proc/modules (default)
> -o /lib/modules/2.4.7-ac6/ (default)
> -m /boot/ (specified)
> CPU: 0
> EIP: 0010:[<c0180a18>]
> Using defaults from ksymoops -t elf32-i386 -a i386
> EFLAGS: 00010002
> eax: 00001000 ebx: c4562368 ecx: 00000000 edx: 00000001
> esi: c4562368 edi: c4a954d4 ebp: 00000001 esp: c6887d88
> ds: 008 es: 0000 ss: 0018
Here is your problem. %es is set to the null segment. I had my
suspicions about the segment reload optimisation in the -ac kernels, and
this proves it. Try backing out the changes to arch/i386/kernel/entry.S
and include/asm-i386/hw_irq.h and see if that fixes the problem.


Brian Gerst
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 12:57    [W:0.154 / U:0.376 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site