[lkml]   [2001]   [Aug]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [patch] zero-bounce highmem I/O
   From: Jens Axboe <>
Date: Wed, 15 Aug 2001 09:50:18 +0200

Dave, comments on that?

I think the new-style sg_list is slightly overkill, too much
stuff. You need much less, in fact, especially on x86.

Take include/linux/skbuff.h:skb_frag_struct, rename it to
sg_list and add a dma_addr_t. You should need nothing else.
The bounce page, for example, is superfluous.

If you bounce, the bounce page can be determined later via the
dma_addr_t right?

And Dave, should I add the 64-bit stuff I started again? :-)

Let me draft something up, and meanwhile you can think about
the changes I suggest above. Ok?

David S. Miller
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 12:57    [W:0.056 / U:0.164 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site