lkml.org 
[lkml]   [2001]   [Jul]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
On Mon, Jul 09, 2001 at 07:34:10AM -0000, linux@horizon.com wrote:
> > Please provide more detailed hardware description and a output of
> > 'cat /proc/isapnp'. IMHO this problem can be solved easily.
>
> Thank you for being so soothing. As you could probably notice, I was a bit
> frustrated.
>
> On the first machine, with the modem (note that I ran isapnp manually, since
> this modem is my net connection!):
>

> Card 1 'MOT15f0:Motorola VoiceSURFR 56K Modem' PnP version 1.0
> Logical device 0 'MOT15f0:Unknown'
> Supported registers 0x2
> Compatible device MOT15f0
> Device is active
> Active port 0xffff,0xffff,0xffff,0xffff,0xffff,0xffff,0xffff,0xffff
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Use of isapnptools package mixed with kernel 2.4.x ISA PNP subsystem is asking
for trouble. Move /etc/isapnp.conf file to some other place and try to reboot.

[SNIP]

> isapnp: Scanning for PnP cards...
> isapnp: Card 'Motorola VoiceSURFR 56K Modem'
> isapnp: Device 'Unknown'
> isapnp: 1 Plug & Play card detected total
> PnP: PNP BIOS installation structure at 0xc00fdbd0
> PnP: PNP BIOS version 1.0, entry at f0000:d20e, dseg at f0000
> Linux NET4.0 for Linux 2.4
> Based upon Swansea University Computer Society NET3.039
> Initializing RT netlink socket
> apm: BIOS version 1.1 Flags 0x03 (Driver version 1.14)
> Starting kswapd v1.8
> parport0: PC-style at 0x378, irq 7 [PCSPP(,...)]
> matroxfb: Matrox Millennium (PCI) detected
> matroxfb: 640x480x8bpp (virtual: 640x13081)
> matroxfb: framebuffer at 0xFE000000, mapped to 0xc6807000, size 8388608
> Console: switching to colour frame buffer device 80x30
> fb0: MATROX VGA frame buffer device
> pty: 256 Unix98 ptys configured
> Serial driver version 5.05b (2001-05-03) with MANY_PORTS SHARE_IRQ SERIAL_PCI ISAPNP enabled
> ttyS00 at 0x03f8 (irq = 4) is a 16550A
> ttyS01 at 0x02f8 (irq = 3) is a 16550A
> ttyS02 at port 0x03e8 (irq = 5) is a 16550A
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Hmm, looks strange to me, it seems that serial driver found your modem and configured
it as /dev/ttyS2. Did you try to test it with minicom for example ?

--
Andrey Panin | Embedded systems software engineer
pazke@orbita1.ru | PGP key: http://www.orbita1.ru/~pazke/AndreyPanin.asc[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2005-03-22 12:56    [W:0.048 / U:19.140 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site