lkml.org 
[lkml]   [2001]   [Jul]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectFilesystem bug? "sync" hangs...
Kernel 2.4.7-pre3 on alpha.

The initial phase of an RPM build is unpacking a tarball and applying
patches, which is a bunch of writes followed by a update of read/write
updates. A lot of write activity, basically. RPM build is running at
normal priority as a normal user.

In another xterm, su'd in a shell that is renice'd to -14, I run "sync"
during all this write activity. It hangs for 17 seconds before I get
impatient, stop counting, and suspend the RPM build process. sync
continues to block, not returning to the command prompt. I run dmesg
(generated read activity?), and sync finally returns.

The RPM build process continues unpacking/writing files without
appearing to slow in window 1 while sync blocks in window 2.

I have not seen this behavior before, but I do not recall trying 'sync'
specifically during heavy write activity before. This behavior is
reproducible.

--
Jeff Garzik | A recent study has shown that too much soup
Building 1024 | can cause malaise in laboratory mice.
MandrakeSoft |
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:56    [W:0.028 / U:0.648 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site