lkml.org 
[lkml]   [2001]   [Jul]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: pcmcia lockup inserting or removing cards in 2.4.5-ac{13,22}
On Thu, Jul 05, 2001 at 12:41:15AM +0000, Trevor Hemsley wrote:
> OK, I've done quite a lot more work on this. It isn't 2.4.5, I'd
> compiled USB support in when I went to 2.4.5 and it's that that causes
> the problems. I backed out all changes made between 2.4.2 and 2.4.5 in
> drivers/pcmcia and that made no difference to the lockup so then I
> went back to the .config file from 2.4.2 and that worked.

Hmm, Cardbus and USB problems... you probably have both Cardbus and
i82365 support in your kernel configuration. Your .config file should
have this:

#
# PCMCIA/CardBus support
#
CONFIG_PCMCIA=y
CONFIG_CARDBUS=y
# CONFIG_I82365 is not set
# CONFIG_TCIC is not set

That fixed it for me for at least three laptops.


Erik

--
J.A.K. (Erik) Mouw, Information and Communication Theory Group, Department
of Electrical Engineering, Faculty of Information Technology and Systems,
Delft University of Technology, PO BOX 5031, 2600 GA Delft, The Netherlands
Phone: +31-15-2783635 Fax: +31-15-2781843 Email: J.A.K.Mouw@its.tudelft.nl
WWW: http://www-ict.its.tudelft.nl/~erik/
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:56    [W:0.153 / U:0.020 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site