lkml.org 
[lkml]   [2001]   [Jul]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectPCI and interrupts
Date
Hello kernel developers

I am asking this question here because of a lack of results with
my post to the linux-parport list. I hope you don't mind.

I have an Intek21 PCI parallel port (PCI vendor id=14DB,
device id=2120) which is advertised as supporting interrupt
sharing. I am writing a custom driver for this card in place
of a previously working custom driver for an ISA parallel port.
The problem is I can not get hardware interrupts to work.

The /proc/pci file reports that the card is using IRQ 11
as does the pci_dev struct. Also pci_read_config_byte tells me
that INTA is being used for this card. I enable interrupts
as with the former ISA device but I get no interrupts (my
ISR is never called upon level triggering pin 10).

I have also tried changing modes in using the ECR register
at base + 0x402 but still no interrupts.

Does anyone know what might be going on with this card? Does
anyone have similar experience with this card?

Thanks once again,
Daniel
_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:57    [W:0.029 / U:0.020 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site