lkml.org 
[lkml]   [2001]   [Jul]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: 2.4.6-preX, 2.4.6...
Date
Joshua writes:
> I have not located exactly [in which patch] the problem began, but if
> try to boot w/2.4.6-preX - 2.4.6, the video goes away. And then it
> seems to lock up the computer. At first I had APGART + DRI + MatroxFB.
> So I removed the FB drivers, and tried again. Same problems. So I
> modularized Agpart, and DRI, [I need them for my X config]. No Change.
> Almost immediatly after 'Uncompressing Linux.....' I see a rush of
> the text across the screen, and then the screen flashes, and blinks, and
> then nothing. I do not even have a chance to see anything at all.

It _sounds_ like an X server problem (screen flashing, going blank). Do
you have another machine available to see if the computer is still alive
(via ping, telnet, ssh, etc), or a serial console?

You could try setting your runlevel to 3 in /etc/inittab, or booting with
"single" on the kernel command line to avoid starting X right away at boot.
If the system boots to single user mode, then it is X that is the problem
(or at least a bad interaction between X and your kernel).

> I can't tell what's locking up, I tried a SysRQ, but got nothing. No
> screen. *sigh* I am not equiped to do this over a serial or parallel
> port. I was hoping that someone would have a clue.

When you say SysRQ, does this include SysRQ-B for rebooting? If so, that
may indicate a total lockup.

Cheers, Andreas
--
Andreas Dilger \ "If a man ate a pound of pasta and a pound of antipasto,
\ would they cancel out, leaving him still hungry?"
http://www-mddsp.enel.ucalgary.ca/People/adilger/ -- Dogbert
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:56    [W:0.046 / U:2.744 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site