lkml.org 
[lkml]   [2001]   [Jun]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectOPL3-SA2 driver and Intel AL400LX onboard sound problems
Hi, 

Just updated to 2.4.5 from 2.2.18 and there seems to be a difference in the OPL3-SA2 sound driver.

I have an Intel AL440LX motherboard with onboard sound, after setting up the sound driver under 2.4.5 I get a strange effect when trying to play any sound files; the files play very slow (like the sample rate is off), the volume is very low (the mixer seems to take no effect) and there is lots of interference (hissing). I only get hissing from the left speaker and the much too slow, very bassy, distorted sound from the right speaker.

This happens when I try to play MP3s from xmms and when I cat a wav straight to /dev/snd.

I've tried setting the card up with isapnp and the kernel ISA PNP features, both have the same effect. Using isapnp under 2.2.18 my sound worked perfectly. I am currently using the kernel ISA PNP features.

When the kernel loads I get:
Jun 9 16:39:22 yoshi kernel: isapnp: Scanning for PnP cards...
Jun 9 16:39:22 yoshi kernel: isapnp: Card 'OPL3-SA3 Snd System'
Jun 9 16:39:22 yoshi kernel: isapnp: 1 Plug & Play card detected total

When sound is initialised I get:
Jun 9 16:39:34 yoshi kernel: opl3sa2: Found OPL3-SA3 (YMF715 or YMF719)
Jun 9 16:39:34 yoshi kernel: <OPL3-SA3> at 0x100
Jun 9 16:39:34 yoshi kernel: <MS Sound System (CS4231)> at 0xe84 irq 5 dma 1,3
Jun 9 16:39:35 yoshi kernel: <MPU-401 0.0 Midi interface #1> at 0x300 irq 5
Jun 9 16:39:35 yoshi kernel: opl3sa2: 1 PnP card(s) found.

/proc/interrupts looks like:

5: 14783 XT-PIC MS Sound System

(rest omitted)

The values in /proc/isapnp appear to match as well (I won't dump that all here though) as do the values in /proc/ioports (I will leave that out too unless requested later). I am fairly sure there is no conflict there.

I had heard murmers that this driver had been through some changes and looking through the list archives has shown that there have been some problems in 2.4.x with this driver before; nothing seems to match my problem though.

Could anyone point me in the direction of trying to solve this problem? It doesn't have to be a patch, I'm fairly good at looking through source, its just that I haven't got a clue where to start. Any tips would be appreciated. Of course, if a fix already exists please point me at it instead of going through it the hard way...!

Thanks in advance.

Robin
--
E-Mail: robin@phaderunner.demon.co.uk
WWW: http://www.phaderunner.demon.co.uk/
GnuPG public key: http://www.phaderunner.demon.co.uk/Robin_Cull.key.asc

"It's easier to ask forgiveness than it is to get permission."
-- Rear Admiral Dr. Grace Hopper (sponsor of COBOL...)

[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2005-03-22 12:55    [W:0.033 / U:0.568 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site