lkml.org 
[lkml]   [2001]   [Jun]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
SubjectRe: ftape and kernel 2.4 problem
Here's a patch I wrote to allow ftape to compile against 2.4.something.
It still works with 2.4.5. I'm not sure if it works entirely (it seems
to), but it compiles and seems to work. Enjoy!

On Thu, Jun 07, 2001 at 05:12:31PM +0200, Friedrich Lobenstock wrote:
> Hi!
>
> As the linux-ftape mailing list is gone I'm asking you guys.
>
> Can someone tell me how to adapt the ftape driver that I can use it
> under kernel 2.4.x (x >= 5)? I'm not that into kernel hacking that
> I know what changed from 2.2.x to 2.4.x. Below is the output of make.
>
> BTW why wasn't the newer ftape driver ported to 2.4 but the stone age
> ftape driver is still in 2.4?
>
> PS: Please CC me because I'm not on linux-kernel.
--
-Steven
In a time of universal deceit, telling the truth is a revolutionary act.
-- George Orwell
diff -ru ftape-4.04a/ftape/lowlevel/ftape-init.h ftape-4.04a.mod/ftape/lowlevel/ftape-init.h
--- ftape-4.04a/ftape/lowlevel/ftape-init.h Mon Jul 3 05:13:06 2000
+++ ftape-4.04a.mod/ftape/lowlevel/ftape-init.h Mon Feb 5 18:58:42 2001
@@ -67,7 +67,7 @@
}
extern inline int ft_sigtest(unsigned long mask)
{
- return (current->signal.sig[0] & mask);
+ return (current->sigpending & mask);
}
extern inline int ft_killed(void)
{
diff -ru ftape-4.04a/include/linux/ftape.h ftape-4.04a.mod/include/linux/ftape.h
--- ftape-4.04a/include/linux/ftape.h Tue Jul 25 06:04:47 2000
+++ ftape-4.04a.mod/include/linux/ftape.h Mon Feb 5 18:59:35 2001
@@ -28,7 +28,7 @@
* for the QIC-40/80/3010/3020 floppy-tape driver for Linux.
*
*/
-
+#define __initlocaldata __initdata
#define FTAPE_VERSION "ftape v4.04a 07/25/2000"

#ifdef __KERNEL__
\
 
 \ /
  Last update: 2005-03-22 12:55    [W:0.041 / U:1.152 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site