lkml.org 
[lkml]   [2001]   [Jun]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Large ramdisk crashes system


On Thu, 7 Jun 2001, Paul Buder wrote:

> I am trying to create a system which boots off of a cd and has no hard
> disks. So it needs ramdisks. But I haven't had much luck creating
> large ones.
>
> I tried on two different boxes. In both cases the kernel is 2.4.5 with
> 'Simple RAM-based file system support' turned on.
>
> One box is a dual Pentium 750 with a gig of ram in it. I had the
> kernel 'Default RAM disk size' set to 800000 for this box. I issued
> the following commands.
>
> mkfs /dev/ram0 400000
> mount /dev/ram0 /mnt
> dd if=/dev/zero of=/mnt/junk bs=1024 count=500000
>
> This is fine, dd creates a 400 meg file, reports there isn't enough
> space and exits. But if I change the first line to
>
> mkfs /dev/ram0 500000
>
> I'm essentially crashed. I can ping the box and switch between virtual
> terminals but that's it. Any program that was running on the other
> virtual terminals is frozen (as in top, tail, login). The dd is frozen
> and can't be control-c'd. so I can't do anything other than powercycle.
> I should have at least 400 megs of ram left for the system so I don't
> get it.
>
> I tried the same thing on a 128 meg box. The results were similar. A 40
> meg ram disk worked. A 60 meg ram disk crashed the box. The numbers
> seem a little odd since in both cases the magic threshold seems to be
> roughly 40% of ram.
>
> I get no messages in the system logfiles nor an oops on the screen.
>
> Any ideas?

Can you get the (traced by ksymoops) backtrace of dd and kswapd
everything is locked?

You can do that with sysrq.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:55    [W:0.052 / U:0.764 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site