lkml.org 
[lkml]   [2001]   [Jun]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectlots of pppd (down) stall SMP linux-2.4.x
Hi folks,

I have a pretty nasty problem w/ pppd (2.4.0) on SMP versions of 2.4.x (I've
tried 2.4.0.SuSE to 2.4.4).
I am running >25 pppds on a Dual-Pentium933, 3GB, Asus CUR-DLS motherboard
(ServerWorks SE). The pppds are running fine (I am using pppoe plugin from
Michael Ostrowski, and/or a user process doing the PPPoE). BUT once I try to
bring the ppds down to fast (killall is a perfect way) the system stalls, i.e.
no Oops, no login etc. however, switching consoles via keyboard works, ping'ing
the IP from the net still works. None of the log files hold any useful
information...
If I bring the pppds down using a slow loop (one kill per second or slower) the
machine does NOT stall.
I'v tried many different SMP related patches from this list (ppp_async, tty) but
none of them helped on my problem.
And - of course - the problem does NOT exist on the same box using the same
kernel base w/o SMP support!!!

Any help is very much appreciated!
Thanks

Immanuel

--
Till Immanuel Patzschke mailto: tip@internetwork-ag.de
interNetwork AG Phone: +49-(0)611-1731-121
Bierstadter Str. 7 Fax: +49-(0)611-1731-31
D-65189 Wiesbaden Web: http://www.internetwork-ag.de





-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:54    [W:0.035 / U:0.408 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site