lkml.org 
[lkml]   [2001]   [Jun]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: ide retry on 2.4.5-ac7
From
On Mon, Jun 04, 2001 at 11:09:33PM +0200, Jens Axboe wrote:
>
> This is not the case that is attempted solve. The above could be a cable
> error (it looks like it). These are usually genuine and indicate a real
> hw problem.

I know about that, but I tried with other cable and the trouble leaves the
same. On the other hand, before kernel 2.4.2 I think, (not sure of the number)
the kernel does not want to activate UDMA on startup even with the option
activated, and this on via mb. At that time, I used to force the DMA with
hdparm, and I had no troubles in dma mode 3 with that hard disk, and I can
remeber that udma mode 4 was even not indicate when I try hdparm -I /dev/hdc,
so I don't know why it detects dma 4, and I did not manage to change that at
boot time.
Another example is the hda, which is an ibm DTLA hard drive. In 2.4.2 a 2.4.3
he made the same error in udma mode4, and since 2.4.4 no troubles anymore... I
find it difficult to believe that it is hardware trouble!
Furthemore, I began this thread because I heard someone else on this mailing
list with the same crc error and I thought the patch in ac4 was in a way to
solve the dma detect fails.

thanks for your help

Mike

>
> --
> Jens Axboe

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:54    [W:0.811 / U:0.020 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site