lkml.org 
[lkml]   [2001]   [Jun]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject2.4.5 Kernel panic: Aiee, killing interrupt handler!
Hello,

I have compiled 2.4.5 four times now, and it just won't boot. I have
compiled and used every previous 2.4 kernel without problems, using the
same configuration. The compiler is gcc 2.95.2, but I also tried gcc 3.0
without success. The system crashes early in the boot process, so I
haven't been able to capture the whole error message. One of the first
things I see scroll by is "Machine Check Exception", then the last three
lines are:

>Code: [20 bytes, variable. Sometimes 20 times "%2x"]
>Kernel panic: Aiee, killing interrupt handler!
>In interrupt handler - not syncing

Now this is an old Compaq LTE 5200 laptop, Pentium 120MHz, 72MB RAM.
cat /proc/pci yields:

PCI devices found:
Bus 0, device 0, function 0:
Host bridge: OPTi Inc. 82C557 [Viper-M] (rev 0).
Bus 0, device 1, function 0:
ISA bridge: OPTi Inc. 82C558 [Viper-M ISA+IDE] (rev 0).
Bus 0, device 2, function 0:
VGA compatible controller: Cirrus Logic GD 7543 [Viking] (rev 0).
Non-prefetchable 32 bit memory at 0xc0000000 [0xc0ffffff].
Non-prefetchable 32 bit memory at 0xc1000000 [0xc1ffffff].

As I said, I had no problems with 2.4.n, n<5. I tried a 2.4.6pre kernel
(5, I think), and that *didn't work* either. I would greatly appreciate if
anyone had any suggestions regarding this. And if they could cc: it to me,
that would be great. Thanks!

David Bragason, <bragason at uni-freiburg dot de>

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 12:55    [W:0.039 / U:0.424 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site